Giter Club home page Giter Club logo

cisco-packet-tracer's Introduction

Cisco-Packet-Tracer

This repository contains various network models and designs that I created or assigned to learn Cisco Packet Tracer. This is also a part of my Computer Network Course.



01. Connecting 2 PCs with a Cross FastEthernet Cable







02. Multiple End Devices are Connected with 1 Switch







03. Behaviour Analysis of Hub and Switch





04. Setup a DHCP Server (Automatic IP Assigning to multiple end devices)





05. Setup a DHCP Server with 3 Switches






06. Setup a VLAN (Virtual LAN)





CLI Commands to setup VLAN on Switch


To add a device (connected with FastEthernet Port 0/1) to VLAN 101, simply write :

enable
configure terminal

interface fastEthernet 0/1

switch port mode access
switchport access vlan 101

no shutdown
exit

To add another device (connected with FastEthernet Port 0/4) to VLAN 101, simply write :

interface fastEthernet 0/4

switch port mode access
switchport access vlan 101

no shutdown
exit

After separting devices to different VLANs, save data permanently to non-volatile memory with this command:

do write memory


07. Setup a Truncated VLAN between 2 Switches





CLI Commands to truncate VLAN on Switch


Suppose, 2 Switches are connected together with each of its FastEthernet 0/24 Port, Then we will write the following command on both of the switches :

enable
configure terminal

interface fastEthernet 0/24

switch port mode trunk



no shutdown
exit

do write memory


08. Send Packets between 2 Different Network with a Router





To setup a router's port (suppose gigabitEthernet 0/1) with an ip address 192.168.5.1, we will write:

enable
configure terminal

interface gigabitEthernet 0/1

ip address 192.168.5.1 255.255.255.0

no shutdown
exit

do write memory


09. Send Packets between 2 Different Network with 3 Router and Static Routing





  • To setup a router's port (suppose gigabitEthernet 0/1) with an ip address 192.168.5.1, we will write:
enable
configure terminal

interface gigabitEthernet 0/1

ip address 192.168.5.1 255.255.255.0

no shutdown
exit

do write memory
  • To forward an ip address of a network (192.168.5.0) to neighbour's router (192.168.60.7), we will write:
enable
configure terminal

ip route 192.168.5.0 255.255.255.0 192.168.60.7

no shutdown
exit

do write memory


10. Inter VLAN Routing

  • VLAN1 and VLAN2 are created using CLI.
  • Usually, we know, same VLAN can communicate together
  • But here, VLAN1 can also send a message to VLAN2 by using the router.
  • For setting up default gateways, never forget to add them also into the same VLAN.




11. Alternative Solution for Inter VLAN Routing (without VLAN)

  • All PCs are set to default VLAN(1)
  • Usually, we know, switch can only communicate with the devices with same IP series.
  • As the IP series of VLAN 1 and VLAN 2 devices are different, so using this concept, switch will only pass messages to same IP devices.
  • But here, there is an one major fault. Changing the device IP will change their VLAN which is unsafe for a network.




© Most Humayra Khanom Rime

cisco-packet-tracer's People

Contributors

h-k-r avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.