Giter Club home page Giter Club logo

environment.nix's Introduction

kickstart.nix

Kickstart your Nix environment.

Table of Contents

Prerequisites

  • Familiarity with terminal commands.
  • An account on GitHub for forking the repository.
  • GitHub CLI (gh) installed for some commands.

Initial Setup

Choose the appropriate setup instructions based on your operating system.

macOS

  1. Install nixpkgs with official script:
sh <(curl -L https://nixos.org/nix/install)
  1. Install nix-darwin with official steps:
nix-build https://github.com/LnL7/nix-darwin/archive/master.tar.gz -A installer
./result/bin/darwin-installer
  1. Answer the following with y to edit your default configuration.nix file:
Would you like to edit the default configuration.nix before starting? [y/n] y
  1. Add the following to configuration.nix to enable nix-command and flakes features:
nix.settings.experimental-features = [ "nix-command" "flakes" ];
  1. Answer the following with y to setup <darwin> in nix-channel (though it won't be used):
Would you like to manage <darwin> with nix-channel? [y/n] y
  1. Fork this repository to create your own flake kickstart.

Note This can be done in the Github UI at: https://github.com/ALT-F4-LLC/kickstart.nix

gh repo fork ALT-F4-LLC/kickstart.nix
  1. Clone your new fork locally to customize:

Note If the following command does not work revist steps 1 & 2.

nix run nixpkgs#git clone https://github.com/<username>/kickstart.nix
  1. Update the following value(s) in flake.nix configuration:
let
    username = "<insert-username>"; # replace
in
  1. Switch to kickstart.nix environment for your system with flake configuration:
darwin-rebuild switch --flake ".#darwin-aarch64" # for M1/M2 Chipsets
darwin-rebuild switch --flake ".#darwin-x86_64" # for Intel or AMD Chipsets

NixOS

  1. Add the following to /etc/nixos/configuration.nix to enable nix-command and flakes features:
nix.settings.experimental-features = [ "nix-command" "flakes" ];
  1. Update you system to reflect the changes:
nixos-rebuild switch
  1. Fork this repository to create your own flake kickstart.

Note This can be done in the Github UI at: https://github.com/ALT-F4-LLC/kickstart.nix

gh repo fork ALT-F4-LLC/kickstart.nix
  1. Clone your new fork locally to customize:

Note If the following command does not work revist steps 1 & 2.

nix run nixpkgs#git clone https://github.com/<username>/kickstart.nix
  1. Update the following value(s) in flake.nix configuration:
let
    username = "<insert-username>"; # replace
in
  1. Switch to kickstart.nix environment for your system with flake configuration:
nixos-rebuild switch --flake ".#nixos-aarch64" # for ARM Chipsets
nixos-rebuild switch --flake ".#nixos-x86_64" # for Intel or AMD Chipsets

Personalizing Your Environment

You can further tailor your Nix environment through configurations.

Darwin

  • nix-darwin system options exist in ./system/darwin.nix
  • home-manager system options exist in ./system/darwin.nix

NixOS

Important The default user password can be found and updated in ./system/nixos.nix.

  • nixos system hardware options exist in ./system/nixos-hardware-configuration.nix
  • nixos system options exist in ./system/nixos.nix
  • home-manager system options exist in ./module/home-manager.nix

Shared

  • nix system options exist in ./module/configuration.nix
  • home-manager user options exist in ./module/home-manager.nix

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    ๐Ÿ–– Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. ๐Ÿ“Š๐Ÿ“ˆ๐ŸŽ‰

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google โค๏ธ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.