Giter Club home page Giter Club logo

gargoyle's Introduction

Gargoyle Router Management Utility

Gargoyle is a third party firmware for routers based on the Openwrt firmware. It can be described at a high level as a front-end to Openwrt, however there are several packages and custom kernel modules which are not included upstream in Openwrt. As a result, Gargoyle cannot be installed as a set-of-packages to an existing Openwrt installation, and is a separate firmware as far as installation is concerned. Gargoyle is open-source software, and aims to be the first open-source firmware project to place a strong focus on creating a user-friendly interface.

Getting Started

As a developer, or even a casual contributor, you should start here at the Gargoyle wiki developer documentation. You should always consult the wiki for up to date information on getting started (as it is maintained by the community, and this readme may not receive as much attention), however as a brief summary...

Prerequisites

The following prerequisites assume a 64bit Ubuntu system. Many devs use virtual machines, and they are perfectly fine for this kind of work.

sudo apt-get install build-essential asciidoc binutils bzip2 gawk gettext git libncurses5-dev libz-dev patch unzip zlib1g-dev lib32gcc1 libc6-dev-i386 subversion flex uglifyjs \
git-core gcc-multilib p7zip p7zip-full msmtp libssl-dev texinfo npm libelf-dev clang flex bison g++ g++-multilib python3-distutils rsync file wget

NOTE Python is also required and needs to be in your path. Python 3 is recommended. For Ubuntu users, it is recommended to install python-is-python3 to solve this issue automatically.

Get the source

You've already found it if you're reading this, but lets get it on your local machine. Choose one of the following commands depending on whether you want to use SSH or HTTPS authentication:

[email protected]:ericpaulbishop/gargoyle.git
https://github.com/ericpaulbishop/gargoyle.git

Then

cd gargoyle

Building Gargoyle

After building is complete, you'll have -src/, built/ and images/ folders. Retrieve your compiled firmwares from images, and the packages from built.

Make all targets

make FULL_BUILD=true

Make a single target (e.g. ar71xx)

make ar71xx FULL_BUILD=true

Make a single profile (e.g. ar71xx.usb_large)

make ar71xx.usb_large FULL_BUILD=true

Make a single target (e.g. ar71xx) without rebuilding Openwrt (just packages)

make ar71xx

Make a custom target

See the wiki for more detailed instructions.

make custom

Install

Please see the relevant Openwrt wiki or ToH entries for your device for the intricacies of installation, upgrading and failsafe for your device.

Where do I get help?

The forums: Gargoyle-Router Forums

Contributing

Please read CONTRIBUTING.md for details on our code of conduct, and the process for submitting pull requests to us.

Reporting an issue or bug

If you have discovered a genuine bug or other shortcoming in the firmware that you would like addressed, please first check the forums to see if it has already been raised and addressed. If the community is not able to address it for you, or the consensus is that it is a genuine bug, please raise an issue in GitHub. NOTE Issues are not the place for feature requests. Please keep these to the forum. Include as much detail as you can, such as:

  • Gargoyle Version
  • Router Make, Model and Version
  • What were you doing when the bug occurred?
  • What happened (what's the bug)?
  • What did you expect to happen (what is your expectation of the proper behaviour)?
  • Can you reproduce the bug everytime, sometimes, rarely? (For rare issues, start with the forums and see if others are seeing the same issue)
  • Exact steps to reproduce the bug

License

Gargoyle is copyright (C) 2008-2019 by Eric Bishop Gargoyle is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License version 2.0 as published by the Free Software Foundation, with the following clarificaiton/exception that permits adpating the program to configure proprietary "back end" software provided that all modifications to the web interface portion remain covered by this license:

The GNU General Public License (GPL) is vague as to what constitutes “mere aggregation” under section 2, and what contitutes a work “based on the Program.” In the special case in which the Program is modified for the purpose of configuring other (potentially GPL-incompatible) software, the combination of the Program and this other software shall be considered "mere aggregation" if and only if the ONLY interaction between the Program and the other software being configured takes place via CGI (Common Gateway Interface) scripts and/or programs. However, these CGI scripts/programs as well as any other additions and modifications necessary for the configuration of the other software shall be considered “based on the Program” for the purposes of this license. Further, if any portion of the Program is used as part of an interface that can be rendered via a web browser, all portions of that interface that can be rendered via a web browser (including, but not limited to, javascript, svg/ecmascript, css, html, and shell/perl/php/other cgi scripts) shall be considered “based on the Program.” This clarification/exception shall apply to the license of all derived works, and must appear in all relevant documentation. If you choose to release your modification to the Program under a later version of the GPL that directly contridicts this clarification/exception, this clarification/exception shall supersede any contradictory language in that version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

Acknowledgments

  • Eric Bishop - Project founder and lead developer
  • The community - For using, supporting and contributing to Gargoyle

gargoyle's People

Contributors

aimacintyre avatar artekw avatar bashfulbladder avatar cappiewu avatar crackself avatar d3fz avatar dpint avatar ericpaulbishop avatar hungaborhorvath avatar ifedorenko avatar ispyisail avatar jan-kiszka avatar lantis1008 avatar lucascborges avatar mari00 avatar n3vu0r avatar neheb avatar nworbnhoj avatar obsy avatar odenninger avatar pbix avatar petbrau avatar roadhawk avatar romanhk avatar ssebastianj avatar stopspazzing avatar thknepper avatar tutsde avatar wildrat avatar yarrouye avatar

Stargazers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

Watchers

 avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar  avatar

gargoyle's Issues

opkg update fails on 1.5.4

---------------------------------------------------------------
|          _____                             _                |
|         |  __ \                           | |               |
|         | |  \/ __ _ _ __ __ _  ___  _   _| | ___           |
|         | | __ / _` | '__/ _` |/ _ \| | | | |/ _ \          |
|         | |_\ \ (_| | | | (_| | (_) | |_| | |  __/          |
|          \____/\__,_|_|  \__, |\___/ \__, |_|\___|          |
|                           __/ |       __/ |                 |
|                          |___/       |___/                  |
|                                                             |
|-------------------------------------------------------------|
| Gargoyle version 1.5.4    | OpenWrt backfire branch         |
| Gargoyle revision 453676a | OpenWrt revision r30752         |
| Built February 29, 2012   | Target  ar71xx/ath9k_usb        |
---------------------------------------------------------------
root@motherbrain:~# opkg install socat
Unknown package 'socat'.
Collected errors:
 * opkg_install_cmd: Cannot install package socat.
root@motherbrain:~# opkg update
Downloading http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/Packages.gz.
Inflating http://downloads.openwrt.org/backfire/10.03.1/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/packages.
Downloading http://www.gargoyle-router.com/packages/gargoyle-1.6/ar71xx/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://www.gargoyle-router.com/packages/gargoyle-1.6/ar71xx/Packages.gz, wget returned 1.

Gargoyle Packages.gz missing?

In trying to differentiate between installed plugins & avalable not-installed plugins, I did gpkg(opkg) update:

opkg update
Downloading package list for attitude_adjustment source...
Package list for attitude_adjustment downloaded successfully.

Downloading package list for gargoyle source...
Package list for gargoyle downloaded successfully.
opkg-orig update
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://www.gargoyle-router.com/packages/gargoyle-1.6/ar71xx/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://www.gargoyle-router.com/packages/gargoyle-1.6/ar71xx/Packages.gz, wget returned 1.

At no point am I seeing gargoyle-plugins like plugin-gargoyle-theme-by-matei which is not installed on my router.

gpkg can't install local .ipkg?

opkg install /tmp/plugin-gargoyle-wifi-survey_1.2.2-2_all.ipk 
WARNING: package list directory "/var/opkg-lists" does not exist
ERROR: No package named plugin-gargoyle-wifi-survey found, try updating your package lists
ls -Al /tmp/plugin-gargoyle-wifi-survey_1.2.2-2_all.ipk
-rw-r--r--    1 root     root         15350 May  7 23:47 /tmp/plugin-gargoyle-wifi-survey_1.2.2-2_all.ipk

Alix - Restore default configuration doesn't work

I'm running Gargoyle 1.5.5 on an Alix 2D2. I try to restore default config using the web UI but my settings are always kept. I also tried to re-install the image without the "preserve settings" option enabled: no success.

I needed to zero-fill the CF and re-flash the firmware (only re-flashing didn't work).

i18n and DDNS

Adding new DDNS sets the entire menu by uci (after save), which causes incorrect coding letters (at least for the PL)

uci set gargoyle.display.firewall_portforwarding='Przekierowanie port�w'
uci set gargoyle.display.firewall_connlimits='Limity po�142�105cze�144'

should be

uci set gargoyle.display.firewall_portforwarding='Przekierowanie portów'
uci set gargoyle.display.firewall_connlimits='Limity połączeń'

Etc.

Languages are missing ancillary translation files

On official 1.5.11:

  • install Spanish or a non-English language using the online Gargoyle package repository via languages or plugins page.
  • activate Spanish or any non-English language
  • view overview.sh
  • view source of page
  • note the missing /i18n/Spanish/overview.js translation file

I think this stems from my not anticipating that languages would be symlinked as you fixed in this commit:
e82762d

So gargoyle_header_footer line 356 would also need to be patched:

if (path_exists(tran_file) == PATH_IS_REGULAR_FILE) {

to

if (path_exists(tran_file) == PATH_IS_REGULAR_FILE || path_exists(tran_file) == PATH_IS_SYMLINK) {

I will have to apply & test later in the evening

basic.sh mode DNS

It is suggested to move the DNS option WAN section, because in the LAN is misleading. By setting a fixed IP on the WAN port you need to remember to set in the LAN DNS options. In any other software, it is in the WAN.
dns

Themes are present, themes.sh webpage MIA

There seems to be a problem with themes detection on Gargoyle 1.5.9+ (May5,2013) build. The themes are included into the firmware. Here is opkg list-installed:

screen shot 2013-05-05 at 2 22 59 am
and
screen shot 2013-05-05 at 2 23 06 am

so clearly when /etc/init.d/gargoyle_themes runs, 1 or both conditions will preclude the themes page becoming visible.

CSS and JS work

This is a multipart bug/TODO item:

  • We should move as many CSS declarations (as feasible) from the haserl templates to CSS files.
  • We should implement minification of the CSS files. This saves us a bunch of space.
  • We should concatenate all the CSS files, since minifiers can do a better job (e.g., coalescing things) when they see everything.
  • We should concatenate all the JS files, since minifiers can also do a better job when they see everything. Also, depending on the minifier (e.g., Google Closure Compiler), a lot of dead-code can be eliminated from Javascript.
  • The JS code could/should be run through JSLint/JSHint.
  • We should move Javascript loading from the top to the bottom of the pages, as per Yahoo's YSlow and Google's Page Speed.

gpkg - Cannot remove manually installed packages

This is very strange:

root@Gargoyle:~# gpkg install ppp
Preparing to install the following packages, which will require 104242 bytes:
    ppp

Preparing to install package ppp...
    Downloading...
    Downloaded ppp successfully.
    Installing ppp...
    Successfully installed ppp.
Installation of packages successful.

root@Gargoyle:~# rm -rf /tmp/opkg-lists
root@Gargoyle:~# gpkg remove ppp
ERROR: Package ppp is installed to destination 'root' which is not writable, cannot uninstall

Reorganization MENU and add submenu VPN and USB and other

Welcome
Is it possible to reorganize the menu Gargoyle as it showed in the pictures? I did so at home. I added at the moment, two additional sections: VPN and USB ... If you agree to such a modification can put up editing that changed my home ... I think the menu is then much more logical.
usb
vpn

gpkg: missing descriptions

Thinking about the firstboot.sh language table to download & install lang.ipks over the internet:

gpkg info -v 'Status,Description' -d plugin_root -o 'js' -r /^plugin-gargoyle-i18n-/

none of the Descriptions are there:

pkg_info = [];
pkg_info["plugin-gargoyle-i18n-Arabic-AR"] = [];
pkg_info["plugin-gargoyle-i18n-Arabic-AR"]["1.0.0-1"] = [];
pkg_info["plugin-gargoyle-i18n-Arabic-AR"]["1.0.0-1"]["Status"] = "install user installed";

pkg_info["plugin-gargoyle-i18n-English-EN"] = [];
pkg_info["plugin-gargoyle-i18n-English-EN"]["1.0.0-1"] = [];
pkg_info["plugin-gargoyle-i18n-English-EN"]["1.0.0-1"]["Status"] = "install user installed";

pkg_info["plugin-gargoyle-i18n-Spanish-ES"] = [];
pkg_info["plugin-gargoyle-i18n-Spanish-ES"]["1.0.0-1"] = [];
pkg_info["plugin-gargoyle-i18n-Spanish-ES"]["1.0.0-1"]["Status"] = "install user installed";

Alix - Time not updated (ntpd missing?)

I'm running Gargoyle 1.5.5 on an Alix 2D2 board and the time is never updated. I tested using a fresh install of 1.5.5 (CF re-flashed).

The problem seems that /usr/sbin/ntpd is missing.

Next gpkg problem

Hi,
next problem with gpkg - I've installed kernel with md5sum abcd. I have two repositories with the same package, one has a different checksum (from the repo OpenWrt), the second is proper (from my repo with checksum abcd). gpkg not able to find and install the right package.

root@Gargoyle:~# gpkg list_installed | grep kernel
kernel - 3.3.8-1-3b70fc7d412617eb97c6bdc7d8fb7844
root@Gargoyle:~# gpkg install kmod-w1
ERROR: Dependency kernel (= 3.3.8-1-d6597ebf6203328d3519ea3c3371a493) of package kmod-w1 is installed,
        but has incompatible version 3.3.8-1-3b70fc7d412617eb97c6bdc7d8fb7844 and is marked as 'hold'
root@Gargoyle:~# 

bug: gpkg install of a Spanish language pack yields error

root@upstairs:~# gpkg install /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk 
ERROR: /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk is not a valid package file, cannot install
root@upstairs:~# opkg install /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk 
Installing plugin-gargoyle-i18n-Spanish-ES (1.0.0-1) to root...
Configuring plugin-gargoyle-i18n-Spanish-ES.

https://raw.github.com/wiki/BashfulBladder/gargoyle-plugins/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk

July 16 build of the i18n-2013 branch

scrolling windows edit container

k0db
1jch

Is it possible to add options scroll panes in the windows editing as many entries as the content does not fit. I solved it this way. At the appropriate file from editing added eg / www / restriction_edit_rule.sh

And the best windows have adapted to the same content as I feel it is a serious BUG

NEW FIREWALL and bug forwarding port on router IP BUG!!!

Hello Eric
Our colleague Obsy of Polish compiled our latest Gargoyle with a new firewall already. However, there is a serious problem with port forwarding on the router's IP. For example, as I have installed the TV TVHeadend and it is the router for IP 192.168.1.1. I want to redirect port 9981 on the router's IP: 192.168.1.1 is ok formed in GUi rule and the file / etc / config / firewall creates an entry:

config redirect 'redirect_enabled_number_0'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

config redirect 'redirect_enabled_number_1'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'udp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

However, the redirection does not work. I can not access the internet on TVHeadend configurations on port 9981. On the other, eg 192.168.1.2 IP forwarding function properly. Manually add the console to the / etc / config / firewall entry:
config rule
option target 'ACCEPT'
option src 'wan'
option proto 'tcp udp'
option dest_port '9981'
option name 'tv'

This entry gets the job done and to enter the port 9981 from the internet works fine. But it should be the option from the GUI. In the old version of the firewall port forwarding option on the IP router to work properly. Everything was getting out of the GUI. In the new version specifically need to use the console. It is suggested to add a section called FIREWALL ROUTER OPEN PORTS and that, in this section, you can open the ports on the IP WAN router, and added to this section of the entries in the / etc / config / firewall type:

config rule
option target 'ACCEPT'
option src 'wan'
option proto 'tcp udp'
option dest_port '9981'
option name 'tv'

and not like:

config redirect 'redirect_enabled_number_0'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

config redirect 'redirect_enabled_number_1'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'udp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

It's 100% easier to userom użwanie and will not need to use the console. Because at this point, only the use of the console's salvation. The OpenWRT from LUCI Section OPEN PORTS ROUTER is and it adds entries:
config rule
option target 'ACCEPT'
option src 'wan'
option proto 'tcp udp'
option dest_port '9981'
option name 'tv'

and in addition the port forwarding section and it adds records:
config redirect 'redirect_enabled_number_0'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

config redirect 'redirect_enabled_number_1'
option name 'tv'
option src 'wan'
option dest 'lan'
option proto 'udp'
option src_dport '9981'
option dest_ip '192.168.1.1'
option dest_port '9981'

The OpenWRT from LUCI to the new firewall works everything correctly.
Please consider a positive case to continue Your soft was fully usable GUI.

bug: restriction with 2 schedules

In testing restrictions.sh, I found its possible to have this:

firewall.rule_1=restriction_rule
firewall.rule_1.is_ingress=0
firewall.rule_1.description=rule_1
firewall.rule_1.active_weekdays=sun,mon,thu,fri,sat
firewall.rule_1.active_hours=00:30-13:15, 14:00-15:00
firewall.rule_1.active_weekly_ranges=Mon 00:30 - Thu 13:15, Fri 14:00 - Fri 15:00
firewall.rule_1.enabled=1

where there are 2 schedules

Make a new rule, use the weekly range
Save changes
Edit rule or reload page & edit rule
change schedule to repeats daily; enter the example timerange
click to turn some days off
hit Close & Apply changes
hit Save Changes

overview.sh

Is there a chance that the file overview.sh swap to WAN section was the section LAN? It is logical ...
beztytuu

CSS files are not minified

Hi.

I just started looking into Gargoyle, as I installed it into a router that not many people seem to have (and OpenWRT compatibility list didn't tell me decisively if it was supported).

So far, I like it a lot, but I would like to get more applets built into busybox and one way to do that would be to save on other resources, like minifying the CSS files. I tried this with the online service at http://www.cleancss.com/ and the results were amazing, with internal.css being shrunk from 24457 bytes to 11912 bytes.

This would be more than enough to save space for a few extra applets even for the routers that have very little memory.

Even when compressed with gzip, the original compressed file goes from 2670 bytes to 2071 bytes. When recompressed with advdef -z4, the file goes from 2590 to 2016, a savings of 574 bytes, which again, is enough to put one extra applet or two in busybox.

Compressing the files with bzip2 or with xz gives worse results than with advdef -z4.

Even when using the vanilla implementation of cssmin, I get gz the reduction from 2590 to 2070, which is still respectable of more than 512 bytes.

A similar thing with common.css brings the minified+compressed file down from 1587 to 1219, which likely makes things fit in an ethernet frame even after the added headers.

If needed, I can provide some patches to the build system or to provide the actual minified files.

Regards,

Rogério Brito.

Missing tab in haserl Makefile

gargoyle/ar71xx-src/build_dir/target-mips_r2_uClibc-0.9.30.1/haserl-0.9.26/src/Makefile
Makefile:474: *** missing separator (did you mean TAB instead of 8 spaces?). Stop.

DyDNS: dnsexit success_regex

I hope this small patch from a different branch isn't a huge issue. I don't want to imperil the i18n branch in letting SourceTree.app move the branches around.

BashfulBladder@f6c28ac

forced update (same IP):

 HTTP/1.1 200 OK
1=IP is the same as the IP on the system

forced update (new IP):

 HTTP/1.1 200 OK
0=Success

without the change, forced update (same IP) resulted in a "Last Update" time of NaN/NaN/NaN NaN:NaN or when reloaded of 'never'.

Spam in log

e7e865b introduce some info logged by syslog:

syslog( LOG_NOTICE, "GOT REQUEST: '%s'",  method_str );
syslog( LOG_NOTICE, "PARSED PATH: '%s'", path);

Can we delete this? This generate lot of information.

New patches

Hi Eric,
I have a few patches affecting on basic.js / basic.sh, associated with new protocols and wan. Previously you did not want to touch basic files. Is now the time to make these changes?

bandwidth , bandwidth_distribution , webmon dont work after compile

Welcome
I compiled the latest from sources GARGOYLE and graphs do not work to me: bandwidth.sh, bandwidth_distribution.sh and webmon.sh. Compile the default settings for ar71xx USB profile. Pages displayed correctly but the graphs and data records do not work. Please help me or tell me what is the reason

scroll bar

Is there a chance to add scroll bars to windows edit (edit container) because in some cases as much value / rules do not fit in the window. Or earn some extra options to adjust the amount of editing windows contents. I got this by adding the relevant sh file from editing specific entry window,

div style="height: 490px; overflow-y: scroll;"
xxxxxxxxxxxxxxxxxxxxxxxx
/div

k0db
1jch
eg
/ www / restriction_edit_rule.sh

!/usr/bin/haserl

?
# This program is copyright © 2008 Eric Bishop and is distributed under the terms of the GNU GPL
# version 2.0 with a special clarification/exception that permits adapting the program to
# configure proprietary "back end" software provided that all modifications to the web interface
# itself remain covered by the GPL.
# See http://gargoyle-router.com/faq.html#qfoss for more information
eval $( gargoyle_session_validator -c "$COOKIE_hash" -e "$COOKIE_exp" -a "$HTTP_USER_AGENT" -i "$REMOTE_ADDR" -r "login.sh" -t $(uci get gargoyle.global.session_timeout) -b "$COOKIE_browser_time" )
gargoyle_header_footer -m -c "internal.css" -j "restrictions.js table.js"
?
fieldset id="edit_container"
legend class="sectionheader" Edycja reguły ograniczenia /legend
div style="height: 490px; overflow-y: scroll;"
?
sed -e '//,$ d' templates/restriction_template
sed -e '/^#/ d' -e "s/([^ ]* )(.*)/\2</option>/" /etc/l7-protocols/l7index
sed -e '1,// d' templates/restriction_template
?
/div

/fieldset

Build broken

The merge of pull request #306 appears to have broken the build.

The last few lines of output for my "make FULL_BUILD=true ar71xx.usb" are:

Package usb-modeswitch is missing dependencies for the following libraries:
libusb-1.0.so.0
make[4]: *** [/home/hohmuth/src/gargoyle/ar71xx-src/bin/ar71xx/packages/usb-modeswitch_2.1.1-1_ar71xx.ipk] Error 1
make[4]: Leaving directory `/home/hohmuth/src/gargoyle/ar71xx-src/package/usb-modeswitch'
make[3]: *** [package/usb-modeswitch/compile] Error 2
make[3]: Leaving directory `/home/hohmuth/src/gargoyle/ar71xx-src'
make[2]: *** [/home/hohmuth/src/gargoyle/ar71xx-src/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[2]: Leaving directory `/home/hohmuth/src/gargoyle/ar71xx-src'
make[1]: *** [world] Error 2
make[1]: Leaving directory `/home/hohmuth/src/gargoyle/ar71xx-src'

This happens whether or not FULL_BUILD=true is specified.

DyDNS: joker.com

ddns-gargoyle package: /etc/ddns_providers.conf:

joker.com has a 'Undefined' section in a browser. Possibly from an extra trailing space in required_variables & required_variable_names.

Dual band

For dual-radio devices (like WDR3600), the patch 8db2ea1 causing incorrect display the correct configuration. If it is selected and saved N + A, the gui shows "dual band" instead of only n + a.

plugin openvpn (after i18n)

function clientNetMismatchQuery(expected, current, newIp)
{
    var continueFun = function(result)
    {
        if(result.match(/Cancel/))
        {
            window.location=window.location
        }
        else
        {
            if(result.match(/Switch/))
            {
                document.getElementById("net_mismatch_action").value = "change"
                newRouterIp = newIp
            }
            if(result.match(/Keep/))
            {
                document.getElementById("net_mismatch_action").value = "keep"
            }
            document.getElementById("openvpn_client_form").submit();
        }
    }

Some comparisons are dependent on the choice of the user. So if are used different languages ​​is it should be modified.

Some trivial errors in C code

Hi.

I was perusing the C files in gargoyle and I found some with elementary mistakes. Would you accept patches? Also, which parts of the tree are gargoyle-specific and which parts are openwrt-specific?

Also, is there any established peer-reviewing process for gargoyle? This would be needed to bar some such elementary errors from slipping and getting merged into the code.

Regards,

Rogério Brito.

gpkg - regexp not working

root@Gargoyle:~# gpkg list-installed *kernel*
root@Gargoyle:~# gpkg list-installed .*kernel.*
root@Gargoyle:~# gpkg list-installed | grep kernel
kernel - 3.3.8-1-3b70fc7d412617eb97c6bdc7d8fb7844

i18n

Problems to be solved by i18n:

  • time (12 or 24), in quotas_template, reboot.sh now is hardcoded AP/PM. Not all countries that use, for example, in Poland, we use 24-hour time. This should be an option when choosing a date format
  • day of week. The same - weeks starts on monday, not sunday :)
  • word order: ex. B <%~ Only %>. Only in Polish is "tylko", but "B tylko" has wrong word order - should be "Tylko B", so some tokens should be modified, ex : <%~ OnlyB %>
  • units: (Kbytes, MBytes) also should be translated

Adopt a uniform Coding Style for gargoyle-specific code

Hi.

One of the things that make the Linux kernel have a highly consistent code is their CodingStyle document, which has principles that are not really restricted to C, but they can transcend to other languages in a similar fashion, like, for instance, JavaScript.

I propose that, for code specific to gargoyle (i.e., not the code that is regularly imported from other places), we adopt the CodingStyle document from the Linux kernel.

I'm filing this as a bug more as a request-for-comments/declaration of intent, before mass reformatting the code for readability and

Regards,

Rogério Brito.

incorrect inclusion of scripts

On login page (hooks), when installed in several languages

<script language="javascript" type="text/javascript" src="/js/common.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="/js/login.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="/js/../hooks/login/070-openvpn.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/English-EN/strings.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/Polish-PL/strings.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/English-EN/login.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="/i18n/Polish-PL/login.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/English-EN/../hooks/login/070-openvpn.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="/i18n/Polish-PL/../hooks/login/070-openvpn.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/English-EN/login.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="/i18n/Polish-PL/login.js?1.6.0--r39952-"></script>
<script language="javascript" type="text/javascript" src="i18n/English-EN/070-openvpn.js?1.6.0--r39952-"></script>

i18n/English-EN/070-openvpn.js is not exist

i18n/English-EN/../hooks/login/070-openvpn.js
/i18n/Polish-PL/../hooks/login/070-openvpn.js is the same file

little thing - missing / at the beginning of certain declarations

coloring of the 3G signal strength

Is it possible to introduce color to the signal strength 3G USB connections? for example,
0 - 29%: red (-113: -95 dBm)
30 - 45%: orange (-93: -85 dBm)
46 - 61%: yellow (-83: -75 dBm)
62 - 100%: green (-73: -51 dBm)
?

minidlna media type

244ed6b

After selected "Media type" choose "save" breaks media_dir. Should look like V,/tmp/usb_mount/(....)/dlna, not /tmp/usb_mount(...)/V,/dlna

set_kernel_timezone

Hi Eric,
is really necessary every time on boot (and shutdown) add and remove set_kernel_timezone from cron? Can we add just once if not exists in cron?

gpkg: Spanish-ES.ipk is not a valid package file, cannot install

I tried to install a language package:

gpkg install /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk 
ERROR: /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk is not a valid package file, cannot install

opkg install /tmp/plugin-gargoyle-i18n-Spanish-ES_1.0.0-1_all.ipk 
Installing plugin-gargoyle-i18n-Spanish-ES (1.0.0-1) to root...
Configuring plugin-gargoyle-i18n-Spanish-ES.

And sure enough, I can change to what appears to be a fully working Spanish UI.

DNS select for WAN

Is it be possible to create an additional section of the DNS choice for WAN connections separately regardless of the LAN DNS? It is necessary to select the DNS is static WAN IP address otherwise no computers in the LAN Internet ... Just as in the example I will choose the LAN DNS Google is starting to work online.
c977fb3c-ea21-11e2-880d-2a160d98a6bb

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.