Giter Club home page Giter Club logo

Comments (6)

eworm-de avatar eworm-de commented on May 20, 2024

I have not seen this... Will try to reproduce later today.
Can you please give exact commands to create the DNS records?

from routeros-scripts.

eworm-de avatar eworm-de commented on May 20, 2024

BTW... I did not test my scripts with RouterOS 7.x at all... Possibly they broke arithmetics with IPv6 addresses? I will check.

from routeros-scripts.

peeterrussak avatar peeterrussak commented on May 20, 2024

Re-tested with 6.48.2 and got same result. And figured it out. This one doesn't get prefix, but IPv6-address of interface:
:local Prefix [ / ipv6 address get [ find where interface=($Comment->"interface") from-pool=$Pool global ] address ];

If interface's address is smth else than :: then it's OR-ed to the static address. I had ::1, which explains +1:

Let's test:
/ipv6 address add address=::100 from-pool=isp interface=bridge
/ip dns static add address=::2 comment="isp-pool-isp, interface=bridge" name=test.test ttl=15m;
/ipv6 dhcp-client disable ether1
/ipv6 dhcp-client enable ether1

With added logging:
:log info ($Prefix);
:set Prefix [ :toip6 [ :pick $Prefix 0 [ :find $Prefix "/64" ] ] ];
:log info ($Prefix);
:log info ("Address is: ". ($RecordVal->"address"));
:local Address ($Prefix | ([ :toip6 ($RecordVal->"address") ] & ::ffff:ffff:ffff:ffff));
:log info ("Updating DNS record for " . ($RecordVal->"name") . ($RecordVal->"regexp") . " to " . $Address);

Creates output:
21:53:29 system,info static dns entry added by admin
21:53:34 system,info DHCPv6 client on ether1 changed by admin
21:53:36 system,info DHCPv6 client on ether1 changed by admin
21:53:37 script,info Updating IPv6 address list with new IPv6 prefix 2001:7d0:87c6:7b00::/56
21:53:37 system,info address list entry changed by admin
21:53:39 script,info 2001:7d0:87c6:7b00::100/64
21:53:39 script,info 2001:7d0:87c6:7b00::100
21:53:39 script,info Address is: ::2
21:53:39 script,info Updating DNS record for test.test to 2001:7d0:87c6:7b00::102

from routeros-scripts.

eworm-de avatar eworm-de commented on May 20, 2024

Ah, got it... Can you please test?

/ system script set comment="url-suffix=\?h=next" ipv6-update
$ScriptInstallUpdate

Also fix the address in dns record, then disable and re-enable.

from routeros-scripts.

eworm-de avatar eworm-de commented on May 20, 2024

Already merged to main branch... Please complain if your issue remains.
... and leave a star if you have not.

from routeros-scripts.

peeterrussak avatar peeterrussak commented on May 20, 2024

Thanks, works now as expected!

from routeros-scripts.

Related Issues (20)

Recommend Projects

  • React photo React

    A declarative, efficient, and flexible JavaScript library for building user interfaces.

  • Vue.js photo Vue.js

    🖖 Vue.js is a progressive, incrementally-adoptable JavaScript framework for building UI on the web.

  • Typescript photo Typescript

    TypeScript is a superset of JavaScript that compiles to clean JavaScript output.

  • TensorFlow photo TensorFlow

    An Open Source Machine Learning Framework for Everyone

  • Django photo Django

    The Web framework for perfectionists with deadlines.

  • D3 photo D3

    Bring data to life with SVG, Canvas and HTML. 📊📈🎉

Recommend Topics

  • javascript

    JavaScript (JS) is a lightweight interpreted programming language with first-class functions.

  • web

    Some thing interesting about web. New door for the world.

  • server

    A server is a program made to process requests and deliver data to clients.

  • Machine learning

    Machine learning is a way of modeling and interpreting data that allows a piece of software to respond intelligently.

  • Game

    Some thing interesting about game, make everyone happy.

Recommend Org

  • Facebook photo Facebook

    We are working to build community through open source technology. NB: members must have two-factor auth.

  • Microsoft photo Microsoft

    Open source projects and samples from Microsoft.

  • Google photo Google

    Google ❤️ Open Source for everyone.

  • D3 photo D3

    Data-Driven Documents codes.